BUG: Teleporter don't work, teleport commands not available

Hi, i´m currently workin on my bachelor-thesis, which includes no-SQL Databases (comparison between RDB an several no-Sql Concepts). OrientDb seems to be a very interesting solution.

However, one importent point of my analysis is to migrate a database from a RDB into a no-SQL DB.
The Teleporter Tool from OrientDB seem perfect. Nevertheless it don’t work.
I tried in many ways to host the DB.

  • Host on Azure, using the image OrientDB Community Edition 2.2 (OrientDB Version 2.2.27)

  • Hosting on Azure, using a Linux VM an installing the latest Version of Orient DB (OrientDB Version 3.0.25) via Docker.

  • Hosting on AWS, using the OrientDB Community Edition 2.2 (OrientDB Version 2.2.31)

Regardless of the implementation, i got the same errors.

  1. Using the Teleporter in OrientDb Studio:
    The first error that occurs, triggered when i navigate from the OrientDB Studio, to the Servers Management and then to the Button on the left site (dashboard/importers). If i analyze the networking actions, it seems that Studio wants to call a Methode with the routing …/profiler/metadata but gets a 405 Method not allowed. If i go to this routing-page i get the error JSON, in which is declared under the key “content” : “Command not found: profiler/metadata”.
    This kind of error is IMO the reason, why the Teleporter does not work.
    If i go further and navigate to the Teleporter, there is another 405 Method not allowed, but this time for the command …/teleporter/drivers. And this part is IMO critical because of this, there is no data in the dropdown Menu from the Database Driver Field.
    Furthermore if i want to test the connection with the “Test Connection” Button, there is another 405-Error with the Method …/teleporter/test. This time however, the Studio Error Prompt is shown which says “Command not fount: teleporter/test
    This eventually leads to the outcome, that the Teleporter is not usable. And again, this exact same behavior is shown in all three hosting options i was testing.

  2. Using the Teleporter Tool with Teleporter.sh script:
    I also tried to migrate my Database with the Teleporter Command Line Tool. But this was also not successful. The first Problem i was facing, is that (for the Hosting Option on Azure with the community edition image) there was no Teleporter.sh in any folder. I looked up the code of the Skript (oteleporter.sh) and insert it manually via an ssh terminal connection in the bin-folder within the OrientDB folder (there are all other scripts like server.sh located). When i´m executing the script, i get the error, that the mainkclass com.orientechnologies.teleporter.main.OTeleporter could not be fount od loaded. Furthermore i get an bash error, that -juser is an unknown command.
    Where i look in the script file, the error has to be in the last command line:

I don’t think this is a normal behavior. Like i said several times before. This kind of errors occurred in so many circumstances regardless fo hosting. How should one be able to use the Teleporter. The most convenient way to use the teleporter is undoubtedly the Studio solution. So can anyone show me a way to how i can use the teleporter on a hosted OrientDB server?

Here are some Screenshots (as a new user I’m not allowed to post more then one image in my post…)