OpenJDK supported?

I successfully installed OrientDB 3.0.18 using Oracle Java 12.

However in light of Oracle’s changes to the license agreement I want to get OrientDB running under OpenJDK, which fails on server start up with a ClassNotFoundException: javax.activation.Datasource.

Can anyone shed light on how to start the server on Open JDK and/or confirm whether Open JDK is supported by OrientDB?


Hi @Ian

this must be related to some JDK classes that were deprecated in v 11 and removed in v 12. I’ll check it ASAP, probably it only needs an additional dependency



Hi Luigi,

Any news on this?


Hi @luigidellaquila, just to confirm I experience the same problem as Ian. I’ve tried with OpenJDK 12 and 11.0.2.

Thanks, Rob.

Hi @RobG

I just pushed a fix on 3.0.x branch, the 3.0.19-SNAPSHOT is already available for download



Thanks Luigi, I can confirm that’s resolved the errors for my installation.

Hi Rob,

can you please let me know how did you set up your linux machine. I am getting an exception (Caused by: java.lang.ClassNotFoundException: javax.activation.DataSource) and i am not sure what i am doing wrong. Is it because of config file or …?
Java version: openjdk 10.0.2 and i have tried to install

Thank you,