Problem with sharded classes

Hi There,

I have a cluster of two computing nodes: “node1” and “node2”.

I created a graph database “mydb” using the following command:
<create database remote:localhost/mydb root root plocal graph>

I also created a class named “C” and added two clusters: “CL1” (configured on node1) and “CL2” (configured on node2) to the class.

This is also the content of default-distributed-db-config.json:

“autoDeploy”: true,
“readQuorum”: 1,
“writeQuorum”: “majority”,
“executionMode”: “undefined”,
“readYourWrites”: true,
“newNodeStrategy”: “static”,
“servers”: {
": “master”
“clusters”: {
“internal”: {
“CL1”: {
“servers” : [ “node1” ]
“CL2”: {
“servers” : [ “node2” ]
”: {
“servers”: ["<NEW_NODE>"]

When I ran “select from cluster:CL2” from the console on node1, it throws an error. It seems remote read from node2 cannot be done. Also when I ran the same command from node2, the same error happens as it cannot remotely read from node1.

This is the error message:

Error: com.orientechnologies.orient.core.exception.OStorageException: Error on executing command: select from cluster:CL2
DB name=“mydb”

Error: java.lang.NullPointerException

I have checked many releases. All have the same error.

I am just wondering why OrienrtDB guys have not fixed it yet as there are a lot of complains on this error (e.g., see this:


Hi, which version of OrientDB are you using?


3.0.13, 3.0.14, and many other releases


I am just wondering why OrientDB guys just launch new releases without fixing old reported issues!!! This is so frustrating :((

Can anyone help me plz.


Have you shared your issue with yet? Please provide additional notes via email and we will try to address your issue.